New IT forum
11 August 2022, 05:56:14 pm *
Welcome, %1$s. Please login or register.

: MiraBox now in stock.
 
Pages: [1]

Author Topic: mirabox boot up  (Read 4469 times)

bkyeyune

  • Newbie
  • *
  • Posts: 4
mirabox boot up
« on: 15 May 2013, 07:15:08 am »

by mistake i did a resetenv and i lost my configs
now Mirabox boots up to ( any help will be appreciated)

i think my problem is with this below and i donot know how to sort it out

bootcmd=usb start; mmc start; tftpboot  0x6400000 172.16.48.100:uImage; bootm 0x6400000
bootargs_root=root=/dev/sda rootfstype=ext3 rootwait rw
bootargs=console=ttyS0,115200 mtdparts=nand_mtd:[email protected](uImage),[email protected](rootfs) rw root=/dev/mtdblock1 rw


List of all partitions:
1f00            4096 mtdblock0 (driver?)
1f01            4096 mtdblock1 (driver?)
1f02         1040384 mtdblock2 (driver?)
No filesystem could mount root, tried:  ext3 ext2 ext4 squashfs vfat msdos iso9660 xfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,1)
Backtrace:
[<c01bd9b4>] (dump_backtrace+0x0/0x110) from [<c00586e8>] (dump_stack+0x18/0x1c)
 r6:00008000 r5:e011602f r4:c06dc430 r3:c06aeeec
[<c00586d0>] (dump_stack+0x0/0x1c) from [<c0058748>] (panic+0x5c/0xd4)
[<c00586ec>] (panic+0x0/0xd4) from [<c0008fb0>] (mount_block_root+0x1d8/0x218)
 r3:00000000 r2:00000020 r1:e0027f60 r0:c0151b5b
[<c0008dd8>] (mount_block_root+0x0/0x218) from [<c00090b4>] (mount_root+0xc4/0xf8)
 r8:00000000 r7:00000013 r6:c022feb0 r5:c06da040 r4:01f00001
[<c0008ff0>] (mount_root+0x0/0xf8) from [<c000925c>] (prepare_namespace+0x174/0x1d4)
 r5:c002aa29 r4:c06da040
[<c00090e8>] (prepare_namespace+0x0/0x1d4) from [<c00084e8>] (kernel_init+0x118/0x158)
 r5:c00083d0 r4:c06d9e00
[<c00083d0>] (kernel_init+0x0/0x158) from [<c022feb0>] (do_exit+0x0/0x5a0)
 r4:00000000 r3:00000000
Logged

noidea

  • Newbie
  • *
  • Posts: 11
Re: mirabox boot up
« Reply #1 on: 15 May 2013, 10:00:03 am »

 Hi,

Here is the default configuration for bootcmd and bootargs :

bootcmd=nand read 0x6400000 0x400000 0x400000; bootm 0x6400000                                                                                           
bootargs=console=ttyS0,115200 $mtdparts ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs   

You have full printenv default value in this post : http://www.newit.co.uk/forum/index.php/topic,4037.0.html

Hopes it can help you

Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!