New IT forum

SheevaPlug => Hardware => Topic started by: patrick295767 on 15 September 2012, 08:22:50 pm

Title: Problem with the mtdblock0
Post by: patrick295767 on 15 September 2012, 08:22:50 pm
Hello,

The sheeva was working over 6 months very well.

Suddenly, after a long use, it seems that my SD is dead. is that correct?

here the output of # fdisk -l ; dmesg

The sheeva plug is not working anymore, i.e. fdisk -l  ???
I cannot find the hdd attached, nor do much.


ssh login to report you the error:

Code: [Select]
eth0: no IPv6 routers present
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 0
Buffer I/O error on device mtdblock0, logical block 0
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 8
Buffer I/O error on device mtdblock0, logical block 1
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 16
Buffer I/O error on device mtdblock0, logical block 2
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 24
Buffer I/O error on device mtdblock0, logical block 3
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 0
Buffer I/O error on device mtdblock0, logical block 0
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 0
Buffer I/O error on device mtdblock0, logical block 0
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 8
Buffer I/O error on device mtdblock0, logical block 1
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 16
Buffer I/O error on device mtdblock0, logical block 2
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 24
Buffer I/O error on device mtdblock0, logical block 3
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 0
Buffer I/O error on device mtdblock0, logical block 0

What to do ?



I removed the sd and tried :
sudo fsck.ext2 -a  /dev/sdc1
sudo fsck.ext3 -a  /dev/sdc2

then restored the image of the SD as I received it from new it , and still same cluster errrors.

my SD is it dead?



thanks in advance
Title: Re: Problem with the mtdblock0
Post by: patrick295767 on 16 September 2012, 12:02:45 pm
http://www.newit.co.uk/shop/proddetail.php?prod=Class_10_Integral

it states : 10 y warranty. Can I give you back this SD card ?
Title: Re: Problem with the mtdblock0
Post by: NewIT_Malcolm on 17 September 2012, 02:46:02 pm
Hi,

Quote
end_request: I/O error, dev mtdblock0, sector 0

These errors are referring to the on-board Nand and not the SD card.