New IT forum
10 August 2022, 10:42:03 pm *
Welcome, %1$s. Please login or register.

: GertDuino now in stock.
 
Pages: [1]

Author Topic: Problem with permission  (Read 2944 times)

eternity007

  • Newbie
  • *
  • Posts: 1
Problem with permission
« on: 19 February 2011, 01:57:08 pm »

Hi buddies,

I need your expert suggestion on GP re-flashing.

I have downloaded kernel and rootfs from http://www.plugcomputer.org/index.php/us/resources/downloads?func=select&id=14.

Initially kernel was not booting due to different ARCH number in u-boot which I have changed in kernel and built. And from rootfs directory I have created ubi-image using the instruction mentioned in http://www.plugcomputer.org/plugwiki/index.php/Recreating_the_GuruPlug_RFS.

So far so good.

But now, when GP boots up, it is unable to start WiFi, SSH etc. There's some problem with permission.
Files in GP are under 1003 GID and owner is 1003 too.
I am unable to find what makes this permission changed. While unzipping rootfs I have used root shell in host machine. Used root too while creating ubi-image.

Can anybody suggest what is the reason for this permission changes????


TIA
Logged

Confusticated

  • New IT customer
  • Hero Member
  • *
  • Posts: 663
Re: Problem with permission
« Reply #1 on: 19 February 2011, 02:28:37 pm »

Quote
unable to find what makes this permission changed
Changed from what ?
Are these not the ownership on the files inside the zip archive ?
Logged
Advocatus Diaboli - My agenda is not to give you the answer, but to guide your thoughts so you derive it for yourself!
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!