New IT forum
27 June 2022, 11:28:45 am *
Welcome, %1$s. Please login or register.

: CubieBoard 2 and Cubietruck both now in stock.
 
Pages: [1]

Author Topic: USB Serial Converter missing  (Read 6764 times)

BenMcDui

  • Newbie
  • *
  • Posts: 12
USB Serial Converter missing
« on: 31 October 2015, 02:57:35 pm »

I was stupid enough to remove the USB Serial Converter A and B from my Windows 10 system. When I connect the Sheevaplug to the USB port, the "New Hardware found" procedure of W10 does not start. What I see in Device Manager is "Other devices, SheevaPlug JTAGKey FT2232D B (2x). I tried to run "CDM v2.12.06 WHQL Certified.exe" and it gave the result "FTDI CDM Driver Package ready for use". Details for SheevaPlug JTAGKey FT2232D B says "no driver installed. But I can't find any driver that will install for this device. I found one that said "The non-Microsoft INF-file does no contain a digital signature" (or similar words).  Please help?
Logged

manscher

  • Newbie
  • *
  • Posts: 21
Re: USB Serial Converter missing
« Reply #1 on: 26 October 2018, 10:07:50 pm »

I know this is old, but maybe someone can use an answer anyway (I know I could when I first found this topic). This worked in Windows 10 for me:

1. Download and unpack the SheevaPlug_Host_SWsupportPackageWindowsHost1.2.zip file from http://www.downloadsnewit.co.uk/CD-images/Sheeva_CD/
2. Turn off driver signature enforcement using the instructions here: https://www.dinolite.us/support/using-older-models-with-windows-8-10 or here: https://www.technipages.com/enable-disable-device-driver-signing (option 1 didn't work for me)
3. Install the Sheevaplug JTAGKEY FT2232D drivers by connecting the USB cable from SheevaPlug, opening Device Manager, right-clicking and selecting "Update Driver", and browse to the unpacked location. Select to install despite the lack of signature. Do the same to install the USB port after the JTAGKEY driver installs.
4. Use PuTTY or another terminal to connect to the COM port now listed in device manager, 115200 baud.
4. Restart windows to require signing again
Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!