New IT forum
27 June 2022, 05:31:15 am *
Welcome, %1$s. Please login or register.

: GertDuino now in stock.
 
Pages: [1]

Author Topic: eSata Raid - starting up slowly, not recognized by GuruPlug  (Read 9021 times)

mabuhay

  • Newbie
  • *
  • Posts: 27
    • myownhomeserver.ch

Hello

I finally managed to use my external Raid-System with the GuruPlug Server Plus through eSata. So far I was using it through USB since I did not manage to make eSata running.

What I figured out was:
- The Raid-System shuts off if there is not power on the USB or eSata port, so every time I start/restart the GuruPlug the Raid-System also has to start again and it needs some time to initialize or whetever
- When the GuruPlug starts up, I get a message saying that the drive is reacting slow and it waits for a while (the message appears a few times until the Raid-System started up). Then the boot-process continues
- When booting is finished, I can't see the Raid-System anywhere
- The Raid-System only gets detected well if I turn on the Raid-System and before it has time to shut down, I also start the GuruPlug

So it seems like the GuruPlug detects the Raid-System when starting up, it also waits until the Raid-Syste is somehow ready but it still does not detect it.

Does anyone has an idea how I could fix my problem? Since I dont need the Raid-System all the time it would be nice if i could just turn it on and start/restart my GuruPlug easily...

Logged
My low-power homeserver with the GuruPlug Server Plus: www.myownhomeserver.ch

NewIT_Marcus

  • Hero Member
  • *****
  • Posts: 960
Re: eSata Raid - starting up slowly, not recognized by GuruPlug
« Reply #1 on: 13 July 2011, 05:00:24 pm »

If you have a JTAG try adding a delay or using the ide reset command.
Logged

mabuhay

  • Newbie
  • *
  • Posts: 27
    • myownhomeserver.ch
Re: eSata Raid - starting up slowly, not recognized by GuruPlug
« Reply #2 on: 13 July 2011, 07:47:28 pm »

Hello

hmm, I read about ide reset before and also tried it, but it does not work (Unknown command 'ide').

And how can I add a delay? It seems like the USB/eSATA power goes up during the boot, so I would need a delay somewhere during the boot process. Im not sure actually when the power goes on, so maybe its right before ther kernel gets unpacked?
The thing is acutally that it is waiting somehow for the Raid-System to boot:
Code: [Select]
ata1: link is slow to respond, please be patient (ready=0)This message appears a few times. Then it continues with:
Code: [Select]
ata1: SRST failed (errno=-16)
ata1: limiting SATA link speed to 1.5 Gbps
ata1: SRST failed (errno=-16)
ata1: reset failed, giving up
And then later these errors (quite a lot of them, just with different sector numbers), only when the eSATA is plugged in. These errors also appear when I try to mount the device (I guess because the device is maybe somehow present but cant be accessed?):
Code: [Select]
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 216
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 224

Logged
My low-power homeserver with the GuruPlug Server Plus: www.myownhomeserver.ch

NewIT_Marcus

  • Hero Member
  • *****
  • Posts: 960
Re: eSata Raid - starting up slowly, not recognized by GuruPlug
« Reply #3 on: 14 July 2011, 07:47:45 am »

When I first saw these errors (on a Sheevaplug):

Code: [Select]
ata1: SRST failed (errno=-16)
ata1: limiting SATA link speed to 1.5 Gbps
ata1: SRST failed (errno=-16)
ata1: reset failed, giving up

I thought that I had bad hardware. I later discovered a problem with my eSATA cable.

You're right; the Guruplug doesn't have the ide reset command. Normally one uses this to kickstart (ie spin-up, if necessary) an eSATA device. linux should then find it, whereas it might not if the ide reset command hasn't been issued.

What I do see in my bootlog is:

Code: [Select]
sata_mv sata_mv.0: version 1.28                                                 
sata_mv sata_mv.0: slots 32 ports 1                                             
scsi0 : sata_mv                                                                 
ata1: SATA max UDMA/133 irq 21                                                 

...

ata1: SATA link up 1.5 Gbps (SStatus 113 SControl F300)

...

ata1.00: ATA-8: WDC WD20EARS-00J2GB0, 80.00A80, max UDMA/133                   
ata1.00: 3907029168 sectors, multi 0: LBA48 NCQ (depth 31/32)

...

scsi 0:0:0:0: Direct-Access     ATA      WDC WD20EARS-00J 80.0 PQ: 0 ANSI: 5   
sd 0:0:0:0: [sda] 3907029168 512-byte logical blocks: (2.00 TB/1.81 TiB)       
sd 0:0:0:0: Attached scsi generic sg0 type 0                                   
sd 0:0:0:0: [sda] Write Protect is off                                         
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPA
mv_xor mv_xor.0: Marvell XOR: ( xor cpy )                                       
 sda: sda1                                                                     
sd 0:0:0:0: [sda] Attached SCSI disk

...

scsi 1:0:0:0: Direct-Access     Generic  STORAGE DEVICE   9909 PQ: 0 ANSI: 0   
sd 1:0:0:0: Attached scsi generic sg1 type 0                                   
sd 1:0:0:0: [sdb] Attached SCSI removable disk                                 
scsi 1:0:0:1: Direct-Access     Generic  STORAGE DEVICE   9909 PQ: 0 ANSI: 0   
sd 1:0:0:1: Attached scsi generic sg2 type 0                                   
sd 1:0:0:1: [sdc] Attached SCSI removable disk                                 

...


I'm not sure what suggestions I can give. I take it that you have tried connecting a different eSATA device, successfully?
Logged

apemberton

  • Full Member
  • ***
  • Posts: 187
Re: eSata Raid - starting up slowly, not recognized by GuruPlug
« Reply #4 on: 14 July 2011, 09:33:02 am »

Not sure if this helps in the case of a RAID - does RAID support have to be built in to the kernel?

I found my stock u-boot on my Guruplugs did not have ide built in. I downloaded and compiled a new u-boot as per http://plugcomputer.org/plugwiki/index.php/Re-building_the_kernel_and_U-Boot. I also compiled a kernel (2.6.38.2 at present) with ide built-in (make menuconfig) rather than loaded as a module. All is working fine, booting from disk and has been so for a couple of months now.
Logged
Tony Pemberton

mabuhay

  • Newbie
  • *
  • Posts: 27
    • myownhomeserver.ch
Re: eSata Raid - starting up slowly, not recognized by GuruPlug
« Reply #5 on: 14 July 2011, 10:42:39 am »

Hello and thank you for the answers so far

@NewIT_Marcus:
The Raid-System works, I tried that already. If I start my GuruPlug right after I started the Raid-System manually, the Raid-system does not go down right away and I can booth the GuruPlug and the Raid-System gets mounted as it should. The only problem is that if the Raid-System wakes up when the GuruPlug is already starting.

@apemberton:
The device that I have is the Promise SmartStor DS4600. It has all raid-functionality built in so it looks like a regular hard drive to the GuruPlug or any other computer.


If I could figure out somehow at which position of the boot process the eSata power goes up, and then add a delay to the boot process right after that point, that could solve my problem.

Or: The message
Code: [Select]
ata1: reset failed, giving upshows that after trying to do the reset for a few times, It does not try any more. If I could adjust the number of reset-attempts to a higher value that could work too. Does anyone know where I can find such a parameter?


Another question:
As I read so far, the eSata should be hot-swappable. Is that correct? I read it in a SheevaPlug-thread here

I just started my GuruPlug and after booting, I turned my Raid-System on. I already tried it a while ago but It did not work, but now it works!!!
When I turn my Raid-System on I get some output on the serial console and when it's finished, I can mount it without problem :)

Ok, I would say my problem is kinda solved. It is much better if I have to take care that I turn the Raid-System on after booting than if I have to reboot every time i need the Raid-System. However, If anyone has a solution to the booting-problem I would appreciate any hint.

mfg
Logged
My low-power homeserver with the GuruPlug Server Plus: www.myownhomeserver.ch

NewIT_Marcus

  • Hero Member
  • *****
  • Posts: 960
Re: eSata Raid - starting up slowly, not recognized by GuruPlug
« Reply #6 on: 14 July 2011, 07:15:12 pm »

If I could figure out somehow at which position of the boot process the eSata power goes up, and then add a delay to the boot process right after that point, that could solve my problem.

Or: The message
Code: [Select]
ata1: reset failed, giving upshows that after trying to do the reset for a few times, It does not try any more. If I could adjust the number of reset-attempts to a higher value that could work too. Does anyone know where I can find such a parameter?

Most likely in the module source, I suppose. I don't know enough about this process to offer anything other than guesses, I am afraid. Just as ide reset is "traditionally" used in eSATA Sheevaplugs to give the drive a kick, I wonder if you would need a two part solution; firstly to apply the kick from linux, and then to add a delay, or a change to the sata behaviour, along the lines of what you have suggested above.

Quote
Another question:
As I read so far, the eSata should be hot-swappable. Is that correct? I read it in a SheevaPlug-thread here

I just started my GuruPlug and after booting, I turned my Raid-System on. I already tried it a while ago but It did not work, but now it works!!!
When I turn my Raid-System on I get some output on the serial console and when it's finished, I can mount it without problem :)

Ok, I would say my problem is kinda solved. It is much better if I have to take care that I turn the Raid-System on after booting than if I have to reboot every time i need the Raid-System. However, If anyone has a solution to the booting-problem I would appreciate any hint.


OK, I'm glad the hot-swapability is allowing you to find a workable solution, and thanks for the update.
Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!