New IT forum
12 August 2022, 03:33:20 pm *
Welcome, %1$s. Please login or register.

: PiHub now in stock.
 
Pages: [1]

Author Topic: Can't boot from SD  (Read 5925 times)

ashi

  • Newbie
  • *
  • Posts: 3
Can't boot from SD
« on: 11 October 2011, 09:48:48 am »

Hello:

I'd bought from New-it the GUI-VNC sd card to my Sheevaplug.

It's used to work and boot, but from some resons somthing has mess.

This is the output while booting from SD:

         __  __                      _ _
        |  \/  | __ _ _ ____   _____| | |
        | |\/| |/ _` | '__\ \ / / _ \ | |
        | |  | | (_| | |   \ V /  __/ | |
        |_|  |_|\__,_|_|    \_/ \___|_|_|
 _   _     ____              _
| | | |   | __ )  ___   ___ | |_
| | | |___|  _ \ / _ \ / _ \| __|
| |_| |___| |_) | (_) | (_) | |_
 \___/    |____/ \___/ \___/ \__|
 ** MARVELL BOARD: SHEEVA PLUG LE

U-Boot 1.1.4 (Dec 27 2009 - 22:03:21) Marvell version: 3.4.27

U-Boot code: 00600000 -> 0067FFF0  BSS: -> 006CFEE0

Soc: 88F6281 A1 (DDR2)
CPU running @ 1200Mhz L2 running @ 400Mhz
SysClock = 400Mhz , TClock = 200Mhz

DRAM CAS Latency = 5 tRP = 5 tRAS = 18 tRCD=6
DRAM CS[0] base 0x00000000   size 256MB
DRAM CS[1] base 0x10000000   size 256MB
DRAM Total size 512MB  16bit width
Addresses 8M - 0M are saved for the U-Boot usage.
Mem malloc Initialization (8M - 7M): Done
NAND:512 MB
Flash:  0 kB

CPU : Marvell Feroceon (Rev 1)

Streaming disabled
Write allocate disabled


USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0 [PRIME]
Hit any key to stop autoboot:  0
SDHC found. Card desciption is:
Manufacturer:       0x03, OEM "SD"
Product name:       "SD16G", revision 8.0
Serial number:      209115741
Manufacturing date: 1/2011
CRC:                0x00, b0 = 0

** Unable to read "/uInitrd" from mmc 0:1 **


And this is the printenv:

Marvell>> printenv
baudrate=115200
loads_echo=0
ipaddr=10.4.50.165
serverip=10.4.50.5
rootpath=/mnt/ARM_FS/
netmask=255.255.255.0
run_diag=yes
console=console=ttyS0,115200 mtdparts=nand_mtd:[email protected](uboot)ro,[email protected](root)
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_root=root=/dev/nfs rw
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
yuk_ethaddr=00:00:00:EE:51:81
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
ethact=egiga0
ethaddr=FO:AD:4E:00:3D:FD
bootargs_console=console=ttyS0,115200
bootcmd_mmc=mmcinit; ext2load mmc 0 0x0800000 /uInitrd; ext2load mmc 0 0x400000 /uImage
bootcmd=setenv bootargs $(bootargs_console); run bootcmd_mmc; bootm 0x400000 0x0800000
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=no
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
bootdelay=3
disaMvPnp=no
enaAutoRecovery=yes
pcieTune=no

Environment size: 1298/131068 bytes
Marvell>>


I can boot with NAND.

Please advise.

Tnx in advance.
Logged

leighbb

  • New IT customer
  • Newbie
  • *
  • Posts: 36
Re: Can't boot from SD
« Reply #1 on: 11 October 2011, 11:08:24 am »

** Unable to read "/uInitrd" from mmc 0:1 **

I guess it cannot find a file called uInitrd in the root of the filesystem.

bootcmd_mmc=mmcinit; ext2load mmc 0 0x0800000 /uInitrd; ext2load mmc 0 0x400000 /uImage
bootcmd=setenv bootargs $(bootargs_console); run bootcmd_mmc; bootm 0x400000 0x0800000

Does that version of u-boot have the ext2ls command?

You could try the following to see what files are in the root directory. It may be u-boot is having trouble reading the filesystem or the file has been deleted.

Code: [Select]
ext2ls mmc 0:1 /


Logged

ashi

  • Newbie
  • *
  • Posts: 3
Re: Can't boot from SD
« Reply #2 on: 11 October 2011, 11:35:20 am »

Tnx!!

When i run this command:

Marvell>>
Marvell>> ext2ls mmc 0:1 /
** Bad partition - mmc 0:1 **
Marvell>>


What happened to it? Is it possible to fix?
Logged

leighbb

  • New IT customer
  • Newbie
  • *
  • Posts: 36
Re: Can't boot from SD
« Reply #3 on: 11 October 2011, 12:11:06 pm »

When i run this command:

Marvell>>
Marvell>> ext2ls mmc 0:1 /
** Bad partition - mmc 0:1 **
Marvell>>


What happened to it? Is it possible to fix?

You say you can boot from NAND.  Have you examined the SD card when booted from NAND?  Alternatively, do you have another Linux machine that can read the SD card?
Logged

ashi

  • Newbie
  • *
  • Posts: 3
Re: Can't boot from SD
« Reply #4 on: 11 October 2011, 12:14:30 pm »

May you explain how to test and investigate the SD while in NAND?

Thank you!
Logged

NewITMalcolm

  • Administrator
  • Sr. Member
  • *****
  • Posts: 394
Re: Can't boot from SD
« Reply #5 on: 13 October 2011, 09:59:22 am »

Ashi,

The NewIT images don't use a uInitrd.

Have a look at this post

http://www.newit.co.uk/forum/index.php/topic,194.0.html

Logged
NewITJames
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!