New IT forum
22 May 2018, 04:12:22 am *
Welcome, %1$s. Please login or register.

: MiraBox now in stock.
 
Pages: [1]

Author Topic: TP2 Power Supply Failure  (Read 968 times)

apemberton

  • Full Member
  • ***
  • Posts: 187
TP2 Power Supply Failure
« on: 08 June 2016, 12:36:15 pm »

After last night's thunderstorm that took out the electricity supply in my area, one of my TP2's failed to come up again. It looks like the internal power supply module failed - probably with a severe mains surge. Whilst I have not looked deeply at the PSU, I suspected it was that since there was no disk activity and no LEDs showing.

Obviously I disconnected the TP2 from the main supply. After much difficulty removing the little setscrews under the rear rubber feet (are they Bristol screws - I couldn't get a good alan key to work) and thus the top case, it was easy to slip the internal PSU out. The larger front ones under the disk drive were easy.

I did some rudimentary checks with a multi-meter and it seemed that the phase (line) fuse was intact (There is no fuse in the Neutral). It seemed that the Bridge rectifier was giving me odd readings but as i don't have a circuit diagram for the PSU that may be OK. So to cut my losses, I decided to discard the PSU and use something else. I thought about using a disused Sheevaplug PSU but that won't fit.

I decided to use a 5V 2.5A wall wart I have in stock. I unsoldered the TP2 PSU from the PCB (take care, there are some very small capacitors between the supply points) with a 40W iron. Cleaned the PTH holes with a solder sucker. I then prepared the wires of the wall wart, tinning them and making sure they would fit the holes. Making sure I had the correct polarity ('+' marked on the board and a stripe on the wall wart's cable), I soldered the wall wart in place. I should have made provision for the power cable before soldering, but that didn't matter too much. I tested the board and disk drive before putting the case back together and all seemed well. I had to cut a small slot in the case for the power wire - I chose to bring the cable out through the empty PSU cavity.

I put the case back together using new crosshead screws rather than the originals to save bother in the future. For neatness, I also put back the 2 pin mains block since it does not have any protruding prongs which might have been dangerous. I did not put a mains wire in to the socket, unnecessary but would not be a bother. Ideally, the 2Pin socket should be blanked off as a reminder.

This might have been a bit of a Kludge but I doubt if spare parts a re available anywhere. This is the first failure of my TP2's in quite a few years and must have been due to the abnormal power surge caused by lightning.

Logged
Tony Pemberton
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!