New IT forum
10 August 2022, 11:44:51 pm *
Welcome, %1$s. Please login or register.

: PiHub now in stock.
 
Pages: [1]

Author Topic: No console output during part of the boot process  (Read 4848 times)

cboyce

  • Newbie
  • *
  • Posts: 2
No console output during part of the boot process
« on: 06 August 2012, 08:48:17 pm »

I installed the Factory-Dreamplug-Ubuntu-fixed-4Gb-1Sep11.img.gz image in to the 4Gb internal SD card, and while the Dreamplug boots to a prompt, it doesn't show any of the console output after "booting the kernel". Any thoughts on what might be going on? Here's the output from the terminal

Code: [Select]
U-Boot 2010.03 (Feb 28 2012 - 15:15:53)
Marvell-DreamPlug

SoC:   Kirkwood 88F6281_A0
DRAM:  512 MB
NAND:  512 MiB
In:    serial
Out:   serial
Err:   serial
Net:   egiga0, egiga1
88E1121 Initialized on egiga0
88E1121 Initialized on egiga1

Hit any key to stop autoboot:  0
Marvell>> printenv
bootcmd=${x_bootcmd_usb}; ${x_bootcmd_kernel}; setenv bootargs ${x_bootargs} ${x_bootargs_root}; bootm 0x6400000;
bootdelay=3
baudrate=115200
x_bootcmd_usb=usb start
ethact=egiga0
ethaddr=F0:AD:4E:01:16:4A
eth1addr=F0:AD:4E:01:16:4B
x_bootargs=consol=ttyS0,115200
x_bootcmd_kernel=fatload usb 0 0x6400000 uImage
filesize=296350
x_bootargs_root=root=/dev/sda2 rootdelay=10
stdin=serial
stdout=serial
stderr=serial

Environment size: 418/131068 bytes
Marvell>> setenv x_bootargs_root root=/dev/sda2 rootdelay=10
Marvell>> saveenv
Saving Environment to NAND...
Erasing Nand...
Erasing at 0x40000 -- 100% complete.
Writing to Nand... done
Marvell>> reset
resetting ...


U-Boot 2010.03 (Feb 28 2012 - 15:15:53)
Marvell-DreamPlug

SoC:   Kirkwood 88F6281_A0
DRAM:  512 MB
NAND:  512 MiB
In:    serial
Out:   serial
Err:   serial
Net:   egiga0, egiga1
88E1121 Initialized on egiga0
88E1121 Initialized on egiga1
Hit any key to stop autoboot:  0
(Re)start USB...
USB:   Register 10011 NbrPorts 1
USB EHCI 1.00
scanning bus for devices... 4 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
reading uImage
...

2712400 bytes read
## Booting kernel from Legacy Image at 06400000 ...
   Image Name:   Linux-2.6.33.6
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2712336 Bytes =  2.6 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

Ubuntu 9.04 ubuntu ttyS0

ubuntu login:

Logged

bigbear59

  • Full Member
  • ***
  • Posts: 118
Re: No console output during part of the boot process
« Reply #1 on: 07 August 2012, 02:13:04 am »

Try
    x_bootargs=console=ttyS0,115200
yours  is
    x_bootargs=consol=ttyS0,115200
no e---------------------^   >:(

Cheers,
BigBear
Logged
Cheers,
BigBear59

cboyce

  • Newbie
  • *
  • Posts: 2
Re: No console output during part of the boot process
« Reply #2 on: 07 August 2012, 05:06:13 am »

Yep, that did it! Thanks a ton, I had stared at that for so long and didn't notice. You rock!
Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!