New IT forum
12 August 2022, 04:07:00 pm *
Welcome, %1$s. Please login or register.

: PiHub now in stock.
 
Pages: [1]

Author Topic: USB Device not ready  (Read 6618 times)

aeve

  • Newbie
  • *
  • Posts: 2
USB Device not ready
« on: 13 May 2010, 03:05:17 pm »

I am very new to this and will do my best to explain the process of how I got to here. I am sorry if the post ends up quite long.

1. Sheevaplug at power on always went to Marvell>> prompt.
The error was:
Reading data from 0x4ff800 -- 100% complete.
 4194394 bytes read: OK
## Booting image at 00800000 ...
Bad Magic Number
Marvell>>

2. I tried various things and got no where, then I did resetenv. This made it worse.
At reset or power on (snipped to save space):
<snip>
U-Boot 1.1.4 (Mar 19 2009 - 16:06:59) Marvell version: 3.4.16
<snip>
NAND:512 MB
*** Warning - bad CRC or NAND, using default environment


Checking for BootROM Routine Errors
<snip>
Load address: 0x2000000
Loading: *T T T T T T T T T T
Retry count exceeded; starting again
## Booting image at 02000000 ...
Bad Magic Number
Unknown command '<NULL>' - try 'help'
Marvell>>

3. ran and completed sheevaplug-installer-v1.0 (for bricked plugs - I guess it was)
But still Marvell>> prompt

4. On instruction from Readme.txt in sheevaplug-installer-v1.0
run recover 1
attached jpg shows output on terminal
It can't access the USB.

I had noticed this during step one above when I was tryinh various things.
I must have used the USB during the installer so what is wrong?

Also attached the output from printenv after the installer was run.

5. From the Marvell>> prompt if I do 'usb start' this is the result.
(Re)start USB...
USB:   scanning bus for devices... 1 USB Device(s) found
       scanning bus for storage devices... 0 Storage Device(s) found
Marvell>>

Do I have a problem with the USB on this plug?
Can anyone point me in a direction to fix this please?

Thank you for your time.

Alison
Logged

NewIT_Marcus

  • Hero Member
  • *****
  • Posts: 960
Re: USB Device not ready
« Reply #1 on: 13 May 2010, 04:31:29 pm »

resetenv doesn't work for you because it resets to a condition whereby it tries to boot from your network. (Actually, probably not even *your* network - see serverip=10.4.50.5).

The installer certainly wrote data to the plug; environment variables "recover1" etc demonstrate this.

The message about failing to read from USB can occur because your USB device is not properly formatted. Try FAT or FAT32, and preferably try a different USB stick too, if you can.

But finally, or firstly, and perhaps most importantly:

Quote
1. Sheevaplug at power on always went to Marvell>> prompt.

What kind of plug did you buy (ex-factory, or multiboot), and did it ever boot fully?
Logged

aeve

  • Newbie
  • *
  • Posts: 2
Re: USB Device not ready
« Reply #2 on: 14 May 2010, 09:29:56 am »

Thank you for the reply.

I tried a different USB stick and run recover1 seemed to work.
I now get the ubuntu log in.

Sorry for forgetting to put the most basic information about the model we are using.
It is a eSata Sheevaplug.
The model number (from the label on the device) is 003-SP1001
SKU #: RD-88F6281-BPLUG-A

Apologies if I seems a little uninformed, I am very new to this.

The plug was bought by a colleague and two others have 'played' with it before I was given it to set up.
So I am not sure what has happened to it, but as I said above it now boots to ubuntu, so now I have to figure out what to do next.

Thank you for your time.

regards
Alison
Logged

NewIT_Marcus

  • Hero Member
  • *****
  • Posts: 960
Re: USB Device not ready
« Reply #3 on: 14 May 2010, 02:43:08 pm »

ok, so maybe the reason why it never progressed beyond the marvell prompt was because of what your colleagues did.

the installer does have a requirement for the formatting of the usb stick, and it's not a complete susprise that some usb sticks might not work.

it seems as though you are up and running now.
Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!