New IT forum
27 June 2022, 10:57:37 am *
Welcome, %1$s. Please login or register.

: PiHub now in stock.
 
Pages: [1]

Author Topic: Howto for Mac OS X 10.8 & JTAG?  (Read 3238 times)

evilscientist

  • Newbie
  • *
  • Posts: 1
Howto for Mac OS X 10.8 & JTAG?
« on: 15 August 2013, 11:56:23 pm »

Howdy folks! New to Dreamplug & I'm trying to get the JTAG working. I've followed as best I can the info in this thread: https://newit.co.uk/forum/index.php/topic,2128.0.html.

I've downloaded and installed the FTDI VCP drivers & modified the plist to contain my vendor and product IDs, but I can neither load nor unload the driver it seems. Here's the relevant plist sections:

<key>Olimex OpenOCD JTAG A</key>
                <dict>
                        <key>CFBundleIdentifier</key>
                        <string>com.FTDI.driver.FTDIUSBSerialDriver</string>
                        <key>IOClass</key>
                        <string>FTDIUSBSerialDriver</string>
                        <key>IOProviderClass</key>
                        <string>IOUSBInterface</string>
                        <key>bConfigurationValue</key>
                        <integer>1</integer>
                        <key>bInterfaceNumber</key>
                        <integer>0</integer>
                        <key>idProduct</key>
                        <integer>40591</integer>
                        <key>idVendor</key>
                        <integer>40584</integer>
                </dict>
                <key>Olimex OpenOCD JTAG B</key>
                <dict>
                        <key>CFBundleIdentifier</key>
                        <string>com.FTDI.driver.FTDIUSBSerialDriver</string>
                        <key>IOClass</key>
                        <string>FTDIUSBSerialDriver</string>
                        <key>IOProviderClass</key>
                        <string>IOUSBInterface</string>
                        <key>bConfigurationValue</key>
                        <integer>1</integer>
                        <key>bInterfaceNumber</key>
                        <integer>1</integer>
                        <key>idProduct</key>
                        <integer>40591</integer>
                        <key>idVendor</key>
                        <integer>40584</integer>
Dunno what I'm doing wrong & help would be greatly appreciated!

Thanks!
Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!