New IT forum
11 August 2022, 05:33:30 pm *
Welcome, %1$s. Please login or register.

: PiHub now in stock.
 
Pages: [1]

Author Topic: [SOLVED] How to automount external drive?  (Read 2747 times)

gilgongo

  • Newbie
  • *
  • Posts: 1
[SOLVED] How to automount external drive?
« on: 16 August 2014, 04:42:28 pm »

Having searched the forums and come up with nothing that seems to work...

I've just bought a SheevaPlug Dev Kit UBIFS today, which appears to be working fine running Debian 6 out of the box. I've stuck an external 500G drive into it, which I've formatted as ext3 and can can mount manually no problem.

So now I want to ensure it's mounted on boot. How do I do that? In Debian, I'd normally put the following line in /etc/fstab:

Code: [Select]
UUID=f86d92da-66a8-4faa-a6b5-f29e311afe47 /mnt/disk ext3 defaults 0 2
But that seems to be ignored on boot, or the plug doesn't boot and falls into admin mode.

THE FIX

So it seems that fsck complains about not being able to find the device on boot. Other forums think this could be solved by putting rootdelay=10 at the end of a boot argument. So, going to Marvell >> and setting the following argument cured it:

bootargs_console 'console=ttyS0,115200 rootdelay=10'

NB: The first time I tried this, it didn't work because I didn't realise (and I didn't spot any help on this) that you have to enclose the environment variable in inverted commas and leave out the equals sign after the variable name.

Leaving this here in case it helps anyone else.


« Last Edit: 16 August 2014, 07:31:35 pm by gilgongo »
Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!